Unable to connect Store/Forward through TLS/SSL Unable to connect Store/F...

Topic: Unable to connect Store/Forward through TLS/SSL

Post Unable to connect Store/Forward through TLS/SSL
by JCvanDoorn on Monday, May 27, 2024

Hi,

I'm trying to use the Store/Forward Service for my domain and things are working well when I use the basic SMTP Service. However, when I try to get the service to push the email to my mail server using TLS/SSL, it won't get the mails through.

I use a certificate from Let's Encrypt on the Synology NAS. And using Synology Mail Server as the backend.

In my logs, I can see the following:
2024-05-27T17:50:34+02:00 blackhole postfix/smtpd[4417]: connect from mx2.dynu.com[107.161.27.201]
2024-05-27T17:50:34+02:00 blackhole postfix/smtpd[4417]: SSL_accept error from mx2.dynu.com[107.161.27.201]: -1
2024-05-27T17:50:34+02:00 blackhole postfix/smtpd[4417]: warning: TLS library problem: error:14209102:SSL routines:tls_early_post_process_client_hello:unsupported protocol:ssl/statem/statem_srvr.c:1685:
2024-05-27T17:50:34+02:00 blackhole postfix/smtpd[4417]: lost connection after CONNECT from mx2.dynu.com[107.161.27.201]
2024-05-27T17:50:34+02:00 blackhole postfix/smtpd[4417]: disconnect from mx2.dynu.com[107.161.27.201] commands=0/0

I would be very grateful if anyone could help me resolve this.



Reply with quote | Report
Post Re: Unable to connect Store/Forward through TLS/SSL
by bcrooker on Wednesday, May 29, 2024

Try reducing the TLS / SSL Profile Level to intermediate if it is set at Modern (Control Panel, Security, Advanced tab).

Reply with quote | Report
Post Re: Re: Unable to connect Store/Forward through TLS/SSL
by JCvanDoorn on Saturday, June 1, 2024

bcrooker wrote:Try reducing the TLS / SSL Profile Level to intermediate if it is set at Modern (Control Panel, Security, Advanced tab).
Thank you bcrooker. That certainly did something as the connection is now established correctly. However, now my mail server does not accept the mail for my users. If I disable SSL/TLS, it does accept the very same mails, so I believe it has to be something with the secure connection.

Any help would be greatly appreciated.

Reply with quote | Report
Post Re: Unable to connect Store/Forward through TLS/SSL
by Finepixels on Wednesday, June 19, 2024

On your Dynu Email service mangement screen, try different options in the "Connection Security" drop down list.

Reply with quote | Report
Sunday, July 21, 2024 1:23 AM
Loading...