A Record question A Record question

Topic: A Record question

Post A Record question
by stormfollower on Tuesday, January 5, 2016

I have a couple of computer set up doing a couple of different things (web server, mail/ftp server). Each computer has a different routable IP: web; xxx.xxx.xxx.165 mail/ftp; xxx.xxx.xxx.165.

I added a second domain to my account for testing purposes: thantos.dynu.com and the wildcard A and AAAA records points to .252. I added a second A record with the alias www.thantos.dynu.com and pointed it to .165.

I checked it was working by pinging both alpha addresses to make sure they resolve correctly. They did. I then stopped the pings and let it sit for a couple of hours as I worked on other things. I went to check the addresses again and both returned the .252 address. I then pinged .165 by numerical address and it worked so I rechecked by alpha addresses and they started returning the correct numerical IP address. I've done this a couple of times.

I've read through the FAQs and Tutorials and Forum looking for an answer as to why this is happening. I haven't had any luck finding a reason/solution. Have I missed something?

Reply with quote | Report
Post Re: A Record question
by timothytw on Wednesday, January 6, 2016

When a hostname yourhost.dynu.com is created, by default mail.yourhostname.dynu.com, www.yourhostname.dynu.com, ftp.yourhostname.dynu.com and server.yourhostname.dynu.com point to the primary IP address.

In your case, www.thantos.dynu.com already points to the primary IP address .252. You added a second A record for www.thantos.dynu.com to point to IP address .165, so currently www.thantos.dynu.com maps to 2 IP addresses. You may do a nslookup at https://www.dynu.com/NetworkTools/DNSLookup.

We suggest that you use an alias other than mail, www, ftp and server to point to a different IP address.

Reply with quote | Report
Monday, July 15, 2024 11:23 AM