Port Check not working for domain name Port Check not working fo...

Topic: Port Check not working for domain name

Post Port Check not working for domain name
by Gustavo Lucena Gomez on Tuesday, June 13, 2017

Hello,

I am trying to use your ddns service correctly. In order to check that everything was working, after registering the free third-level domain glucenag.dynu.net, I went to your "Port Check" tool page and checked that port 4040 was accessible for my public IP address (the one displayed on your website at the top right corner when I log in). Your port check tool says "success", and the webpage canyouseeme.org agrees. All of this is consistent since I've forwarded port 4040 on my router for my machine.

However, when I enter "glucenag.dynu.net" instead of my public IP address in the port check tool of your website, it says "fail" (on the same port!). I would guess that this is bad.

To try and confirm, I went to your "ping" tool, but there it fails (100% packet loss) in both cases: whether I enter the IP or the domain name.

Moreover, I am running Ubuntu 16.04 with the pre-installed ddns client, for which I have configured the /etc/ddclient.conf exactly as you indicate on your config example which I downloaded from your website (of course I wrote in my username and password, but otherwise it is a copy paste).

However when I check that ddns is running by typing sudo /etc/init.d/ddclient status, it spits out "bad authorisation (username or password)". Obviously I have entered my username and password correctly in the config file, so that can't be the issue. More precisely, if that helps, here is my /etc/ddclient.conf file:

# Configuration file for ddclient generated by debconf
#
# /etc/ddclient.conf

# check every 60 seconds
daemon=60
# log update msgs to syslog
syslog=yes
# mail all msgs to root
mail=root
# mail failed update msgs to root
mail-failure=root
# record PID in file.
pid=/var/run/ddclient.pid
# use ssl-support. Works with ssl-library
ssl=yes
# get ip from server.
use=web, web=checkip.dynu.com/, web-skip='IP Address'
# default server
server=api.dynu.com
# default login
login=glucenag
# default password
password=blablabla
protocol=dyndns2
glucenag.dynu.com

where instead of bla bla bla I've entered my dynu password, obviously.

What could be wrong ?

Many thanks in advance,

Gustavo

Reply with quote | Report
Post Re: Port Check not working for domain name
by rahsharma on Tuesday, June 13, 2017

Gustavo Lucena Gomez wrote:Hello,

I am trying to use your ddns service correctly. In order to check that everything was working, after registering the free third-level domain glucenag.dynu.net, I went to your "Port Check" tool page and checked that port 4040 was accessible for my public IP address (the one displayed on your website at the top right corner when I log in). Your port check tool says "success", and the webpage canyouseeme.org agrees. All of this is consistent since I've forwarded port 4040 on my router for my machine.

However, when I enter "glucenag.dynu.net" instead of my public IP address in the port check tool of your website, it says "fail" (on the same port!). I would guess that this is bad.

To try and confirm, I went to your "ping" tool, but there it fails (100% packet loss) in both cases: whether I enter the IP or the domain name.

Moreover, I am running Ubuntu 16.04 with the pre-installed ddns client, for which I have configured the /etc/ddclient.conf exactly as you indicate on your config example which I downloaded from your website (of course I wrote in my username and password, but otherwise it is a copy paste).

However when I check that ddns is running by typing sudo /etc/init.d/ddclient status, it spits out "bad authorisation (username or password)". Obviously I have entered my username and password correctly in the config file, so that can't be the issue. More precisely, if that helps, here is my /etc/ddclient.conf file:

# Configuration file for ddclient generated by debconf
#
# /etc/ddclient.conf

# check every 60 seconds
daemon=60
# log update msgs to syslog
syslog=yes
# mail all msgs to root
mail=root
# mail failed update msgs to root
mail-failure=root
# record PID in file.
pid=/var/run/ddclient.pid
# use ssl-support. Works with ssl-library
ssl=yes
# get ip from server.
use=web, web=checkip.dynu.com/, web-skip='IP Address'
# default server
server=api.dynu.com
# default login
login=glucenag
# default password
password=blablabla
protocol=dyndns2
glucenag.dynu.com

where instead of bla bla bla I've entered my dynu password, obviously.

What could be wrong ?

Many thanks in advance,

Gustavo
Hostname glucenag.dynu.net appears to point to IP address 217.246.191.102 at this time. But I cannot reach your website at http://glucenag.dynu.net:4040. Is the IP address I have specified correct? Could you check using the below link?

https://checkip.dynu.com

Reply with quote | Report
Post Re: Port Check not working for domain name
by glucenag on Tuesday, June 13, 2017

Hello,

I have solved part of the problem (I forgot to change .com to .net in the config file). Now, in your port check tool, my port 4040 appears as open in both instances: both when I enter the public IP of the machine or when I enter glucenag.dynu.net

My remaining problem is with your ping tool: when trying to ping my machine, your tool says "FAIL ... 100% packet loss". And this fails in both cases (whether I enter the IP or the domain name).

What does this mean and is it bad ? My idea is to try and set up a PLEX server, but I do not wish to give a static IP to my machine for security reasons, and hence I need a service such as yours.

Sincerely,

Reply with quote | Report
Post Re: Re: Port Check not working for domain name
by timothytw on Tuesday, June 13, 2017

glucenag wrote:Hello,

I have solved part of the problem (I forgot to change .com to .net in the config file). Now, in your port check tool, my port 4040 appears as open in both instances: both when I enter the public IP of the machine or when I enter glucenag.dynu.net

My remaining problem is with your ping tool: when trying to ping my machine, your tool says "FAIL ... 100% packet loss". And this fails in both cases (whether I enter the IP or the domain name).

What does this mean and is it bad ? My idea is to try and set up a PLEX server, but I do not wish to give a static IP to my machine for security reasons, and hence I need a service such as yours.

Sincerely,
Ping is not guaranteed to work as many routers do not respond to ICMP packets. This should not be a problem as long as your hostname is mapped to the correct IP address and you can access the ports needed to run the service you need. You can also check your router and firewall settings to enable ping.

Reply with quote | Report
Saturday, February 16, 2019 8:46 AM