Mikrotik script giving LAN IP address Mikrotik script giving LA...

Topic: Mikrotik script giving LAN IP address

Post Mikrotik script giving LAN IP address
by mohamed saffar on Thursday, January 14, 2016

There is some thing wrong with the script it giving me router internal ip not wan ip

Reply with quote | Report
Post Re: Mikrotik script giving LAN IP address
by timothytw on Friday, January 15, 2016

Could you please post your script here so that we may take a look?

Reply with quote | Report
Post Re: Mikrotik script giving LAN IP address
by lokka on Friday, January 15, 2016

/system script
add name=Dynu
policy=read,write,test
source=":global ddnsuser mydynusuername
:global ddnspass "dynupassword"
:global theinterface "IN"
:global ddnshost "myhost.dynu.com"
:global ipddns [:resolve $ddnshost];
:global ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]
:if ([ :typeof $ipfresh ] = nil ) do={
:log info ("DynuDDNS: No IP address on $theinterface .")
} else={
:for i from=( [:len $ipfresh] - 1) to=0 do={
:if ( [:pick $ipfresh $i] = "/") do={
:set ipfresh [:pick $ipfresh 0 $i];
}
}
:if ($ipddns != $ipfresh) do={
:log info ("DynuDDNS: IP-Dynu = $ipddns")
:log info ("DynuDDNS: IP-Fresh = $ipfresh")
:log info "DynuDDNS: Update IP needed, Sending UPDATE...!"
:global str "/nic/update?hostname=$ddnshost&myip=$ipfresh"
/tool fetch address=api.dynu.com src-path=$str mode=http user=$ddnsuser password=$ddnspass dst-path=("/Dynu.".$ddnshost)
:delay 1
:global str [/file find name="Dynu.$ddnshost"];
/file remove $str
:global ipddns $ipfresh
:log info "DynuDDNS: IP updated to $ipfresh!"
} else={
:log info "DynuDDNS: dont need changes";
} }

Reply with quote | Report
Friday, March 29, 2024 5:47 AM
Loading...