Domain name does not seem to be active Domain name does not seem...

Topic: Domain name does not seem to be active

Post Domain name does not seem to be active
by hgkrug1 on Saturday, March 9, 2019

Dear Support,

I run Ubuntu 18.10. I have installed ddclient as per https://help.ubuntu.com/community/DynamicDNS.

I have then opened the firewall:
$ sudo ufw status verbose
[sudo] password for gert:
Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing), disabled (routed)
New profiles: skip

To Action From
-- ------ ----
22/tcp ALLOW IN Anywhere
80/tcp ALLOW IN Anywhere
443/tcp ALLOW IN Anywhere
80,443/tcp ALLOW IN Anywhere
80,443/tcp (Apache Full) ALLOW IN Anywhere

However, I seem unable to SSH into the PC.

Any assistance you can offer?
Best wishes
Gert Kruger

Reply with quote | Report
Post Re: Domain name does not seem to be active
by gary1987 on Friday, March 29, 2019

Can you share your DDClient config?

Reply with quote | Report
Post Re: Domain name does not seem to be active
by hgkrug1 on Monday, April 1, 2019

Thanks. I used the instructions at https://help.ubuntu.com/community/DynamicDNS. When I test the domain name at https://www.dynu.com/en-US/NetworkTools/DNSLookup it provides the correct internal IP address, so it seems to me the client function works.

Here is the configuration setup that I have used:

# ddclient configuration for Dynu
#
# /etc/ddclient.conf
daemon=60 # Check every 60 seconds.
syslog=yes # Log update msgs to syslog.
mail=root # Mail all msgs to root.
mail-failure=root # Mail failed update msgs to root.
pid=/var/run/ddclient.pid # Record PID in file.
use=web, web=checkip.dynu.com/, web-skip='IP Address' # Get ip from server.
server=api.dynu.com # IP update server.
protocol=dyndns2
login=myusername # Your username.
password=YOURPASSWORD # Password or MD5 of password.
MYDOMAIN.DYNU.COM # List one or more hostnames one on each line.
MYDOMAIN.COM

Reply with quote | Report
Post Re: Domain name does not seem to be active
by hgkrug1 on Monday, April 1, 2019

I figured out that the router should be set for port forwarding. I changed that as per instruction for my router.

I was able to see port 3306 (Mysql) with the "current IP" using https://www.yougetsignal.com/tools/open-ports/ is open. When I change to the domain name (huisubuntu.nl) it is closed?

Any more help?

Reply with quote | Report
Post Re: Domain name does not seem to be active
by hgkrug1 on Monday, April 1, 2019

Forgot to mention, port 22 (80, 443) for SSH is not open as well. As I indicated on the first message, my firewall is open for SSH (etc).

Reply with quote | Report
Post Re: Domain name does not seem to be active
by hgkrug1 on Monday, April 1, 2019

One more point. I have also tried removing the Firewall from the router. Ports are still all closed, both for "current internal IP" and the domain name (huisubuntu.nl).

Reply with quote | Report
Post Re: Re: Domain name does not seem to be active
by hgkrug1 on Monday, April 1, 2019

hgkrug1 wrote:I figured out that the router should be set for port forwarding. I changed that as per instruction for my router.

I was able to see port 3306 (Mysql) with the "current IP" using https://www.yougetsignal.com/tools/open-ports/ is open. When I change to the domain name (huisubuntu.nl) it is closed?

Any more help?
The setup for port forwarding for my router is described at https://portforward.com/huawei/b315s-22/v2/

Reply with quote | Report
Sunday, May 19, 2019 11:48 PM