Connection security settings in "email store/forward" Connection security setti...

Topic: Connection security settings in "email store/forward"

Post Connection security settings in "email store/forward"
by Michal Machnicki on Sunday, February 28, 2016

Hi,
I bought subscription for email store/forward service and I'm trying to configure email server on Synology DiskStation 214+. I have some concerns about connection security - I can't find anywhere description of field "Connection security" in manage email services and the only configuration which works for me is when the connection security is set to None. It's alarming for me and probably I just don't understand how to set correctly settings of ssl/tls. Can you explain me what does the field exactly do and possibly help me with establishing secure connection between your server and my DiskStation?

SMTP settings on my DiskStation which allow me to send/receive emails when security settings is set to None:
- port: 2525
- Enable SMPT-SSL: on; port 465
- Enable SMTP-TLS: on; port 587
- SMTP Relay: off

Reply with quote | Report
Post Re: Connection security settings in "email store/forward"
by timothytw on Sunday, February 28, 2016

Please find the explanation of SSL/TLS connection below:

With SSL/TLS option enabled, the communication will be encrypted using either SSLv3 or TLS. Directly after our server has established a connection with the your email server, it will perform a SSL/TLS handshake. If the handshake fails, the connection will be terminated.

As a part of the SSL/TLS handshake, our server will verify that your server has a correct certificate. This includes several things, for example:

    Your email server has a certificate.
    The certificate is currently valid
    The certificate is trusted
    The certificate is issued for a host name which matches the host name our server connected to.
    The certificate has not been revoked.

If one of these steps fail, the certificate check fails.

Reply with quote | Report
Friday, November 17, 2017 9:44 PM