SSL issues at HAProxy SSL issues at HAProxy

Topic: SSL issues at HAProxy

Post SSL issues at HAProxy
by LIANG WONG on 2017年5月19日

Hi, I have tried concatening the private key, the intermediate cert, and the 2017 cert into a pen from the ones I received from you but still not working at my HAProxy. Please help.

'bind 0.0.0.0:443' : inconsistencies between private key and certificate loaded from PEM file.

Reply with quote | Report
Post Re: SSL issues at HAProxy
by CobyDeCock on 2017年5月21日

LIANG WONG wrote:Hi, I have tried concatening the private key, the intermediate cert, and the 2017 cert into a pen from the ones I received from you but still not working at my HAProxy. Please help.

'bind 0.0.0.0:443' : inconsistencies between private key and certificate loaded from PEM file.
Below is the format of the PEM file. I think you may have got the order of the certificate, intermediate certificate and root certificate wrong. I recommend you first put just the private key and certificate into the PEM file and see how that goes. Then add in the intermediate at the end and verify.

-----BEGIN RSA PRIVATE KEY-----
(Your Private Key: domainname.key)
-----END RSA PRIVATE KEY-----
-----BEGIN CERTIFICATE-----
(Your Primary SSL certificate: domainname.crt)
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
(Your Intermediate certificate: intermediate1.crt)
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
(Your Root certificate: root.crt)
-----END CERTIFICATE-----

Reply with quote | Report
Post Re: SSL issues at HAProxy
by clewlb on 2017年5月21日

Concatenating the certs in below order works for me.

1) Root Cert
2) Intermediate Cert
3) Private Key

Thanks.

Reply with quote | Report
2018年7月20日 15:17