Community Forum - Create Topic  Community Forum - Create Topic

Author Topic: Port check not working?

Samuel Merton

Joined: 11/10/2001

Post Port check not working?
Monday, May 18, 2015 10:34:00 AM

I have setup my email server along with appropriate settings in the router for port forwarding for ports 25, 143, 587 etc. When I do a port check for port 25, it fails even though all of my settings are correct. I have the same settings for other ports and it succeeds.

Does the port check work for all ports accurately?

Georges Darien

Joined: 1/25/2011

Post Re: Port check not working?
Monday, May 18, 2015 10:36:20 AM

samuelm wrote:I have setup my email server along with appropriate settings in the router for port forwarding for ports 25, 143, 587 etc. When I do a port check for port 25, it fails even though all of my settings are correct. I have the same settings for other ports and it succeeds.

Does the port check work for all ports accurately?


Have you opened port 25 in the firewall of the machine hosting the email server as well? Is there some kind of security settings in your email server to not respond to some types of connections?

Victor Antoine

Joined: 7/17/2005

Post Re: Port check not working?
Monday, May 18, 2015 10:38:19 AM

samuelm wrote:I have setup my email server along with appropriate settings in the router for port forwarding for ports 25, 143, 587 etc. When I do a port check for port 25, it fails even though all of my settings are correct. I have the same settings for other ports and it succeeds.

Does the port check work for all ports accurately?


Some routers have a setting to block both inbound and outbound access to port 25 by default. You should check the documentation of your router to see if this is the case.

Samuel Merton

Joined: 11/10/2001

Post Re: Port check not working?
Monday, May 18, 2015 10:41:46 AM

After a lot of tail swinging, it turned out that my ISP blocks port 25 as well as other 'well known' ports.

To resolve the issue, I setup the email store/forward service and realized that its quite a bit of pain to maintain my own email server so I just changed it to the full service email. It was all a worthy experience though.


It is currently Friday, December 09, 2016 9:58 PM Mountain Standard Time