DDNS Won't Update DDNS Won't Update

Topic: DDNS Won't Update

Post DDNS Won't Update
by mharunian on 07 October 2020

Hi there,

I'm having trouble updating my server. I am using my Raspberry Pi and whenever I execute the file that contains " echo url="https://api.dynu.com/nic/update?username=USERNAME&password=PASSWORD" | curl -k -o ~/dynudns/dynu.log -K - " it doesn't show an updated time on the DDNS webpage. My account username and password are also both correct. The script runs with no problems as shown in the picture attached. Is it updating but just not showing it or have I done something wrong?

Reply with quote | Report
Post Re: DDNS Won't Update
by timothytw on 07 October 2020

The response if the IP address has not changed will be 'NOCHG' and the date won't change. If you change the IP address through the Control Panel and then run the script it should update the IP address and the date/time of update as well.

It seems that curl is downloading the response but the shell script is not setup to output it. You can output the response using 'cat' or any other manner to the screen so you can see it after it is downloaded.

Reply with quote | Report
Post Re: Re: DDNS Won't Update
by elarry on 03 December 2022

timothytw wrote:The response if the IP address has not changed will be 'NOCHG' and the date won't change. If you change the IP address through the Control Panel and then run the script it should update the IP address and the date/time of update as well.

It seems that curl is downloading the response but the shell script is not setup to output it. You can output the response using 'cat' or any other manner to the screen so you can see it after it is downloaded.
Would you mind elaborating on how to diagnose and fix the problem, as I'm having exactly the same one. I'm using the commands and script provided by Dynu (https://www.dynu.com/DynamicDNS/IPUpdateClient/RaspberryPi-Dynamic-DNS). I used my username and the MD5 Hash of my IP Update password in the script. However, the Last Update timestamp on the webpage didn't change. I did see in /var/log/syslog that cron was running the script at the set interval, and I didn't see any error. Did I miss anything? Many thanks in advance.

Reply with quote | Report
29 January 2023 16:27
Loading...